0Chain
Search…
Step 1: Set up the project

System Requirements

Required Free Space: 30 GB OS: Linux (Ubuntu Preferred) Mac(M1 or Intel) Setting up the project on Mac has additional requirements which can be found here Ram: 8GB Minimum,16 GB Recommended CPU: 8 Core CPU Minimum, 16 Core CPU Recommended

Prerequisites

Docker

1.Update the package index and install packages.
sudo apt-get update
2.Install the necessary Docker dependencies
sudo apt-get install \
apt-transport-https \
ca-certificates \
curl \
gnupg \
lsb-release
3.Add Docker's official GPG key:
curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo gpg --dearmor -o /usr/share/keyrings/docker-archive-keyring.gpg
4.Set up a stable repository using the following command.
echo \
"deb [arch=amd64 signed-by=/usr/share/keyrings/docker-archive-keyring.gpg] https://download.docker.com/linux/ubuntu \
$(lsb_release -cs) stable" | sudo tee /etc/apt/sources.list.d/docker.list > /dev/null
5.Install the latest version of Docker Engine and containerd
sudo apt-get update
sudo apt-get install docker-ce docker-ce-cli containerd.io
6.Verify whether the Docker is successfully installed using.
docker --version
Sample Response:
Docker version 20.10.7, build f0df350

Docker Compose

1.Run this command to download the current stable release of Docker Compose:
sudo curl -L "https://github.com/docker/compose/releases/download/1.29.2/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose
2.Apply executable permissions to the binary:
sudo chmod +x /usr/local/bin/docker-compose
3.Verify whether the docker-compose is successfully installed using.
docker-compose --version
Response:
docker-compose version 1.29.2, build 1110ad01

Cloning the Repositories

Deploying the 0Chain network requires cloning of the GitHub repos below.
0chain
git clone https://github.com/0chain/0chain.git
blobber
git clone https://github.com/0chain/blobber.git
0dns
git clone https://github.com/0chain/0dns.git
Confirm whether all the cloned directories exist.
0chain/
blobber/
0dns/

Copy link
On this page
System Requirements
Prerequisites
Docker
Docker Compose
Cloning the Repositories